Tulare Superior Court Maintenance
Incident Report for InfoTrack US System
Resolved
This incident has been resolved.
Posted Jan 24, 2023 - 11:35 EST
Monitoring
Tulare Superior Court is currently under maintenance until 7 AM PST on 1/24/23. Due to the nature of the maintenance, eFiling may be unavailable during this time.
Posted Jan 23, 2023 - 23:32 EST
This incident affected: California eFiling (Tulare County).