Maryland Record Search Portal Outage
Incident Report for InfoTrack US System
Resolved
The issue with the Maryland Record Search Portal has been resolved.
Posted Apr 17, 2024 - 16:26 EDT
Identified
Judicial Information Services (JIS) is aware of an outage with the Maryland Record Search Portal and we are working with the vendor to restore services.
Posted Apr 17, 2024 - 13:41 EDT
This incident affected: Maryland eFiling.