EFileGA Payment Processing Issues
Incident Report for InfoTrack US System
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 17:24 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 17, 2024 - 17:19 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 17, 2024 - 17:10 EDT
Identified
eFileGA is experiencing intermittent payment processing issues. The team is working with the payment processing vendor to resolve the issue as quickly as possible.
Posted Apr 17, 2024 - 13:39 EDT
This incident affected: Georgia eFiling.