eFileTX Payment Processing Issues
Incident Report for InfoTrack US System
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 17:45 EDT
Investigating
eFileTexas is experiencing intermittent payment processing issues. The team is working with the payment processing vendor to resolve the issue as quickly as possible.
Posted Apr 17, 2024 - 11:29 EDT
This incident affected: Texas eFiling.