San Diego Superior Court is Experiencing Technical issues
Incident Report for InfoTrack US System
Resolved
This incident has been resolved.
Posted Jun 05, 2023 - 22:02 EDT
Investigating
San Diego Superior Court is Experiencing Issues Affecting Case Search and Submissions to the court. We will provide an update when we have more information.
Posted Jun 05, 2023 - 16:22 EDT
This incident affected: California eFiling (San Diego County: Civil).