Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 11, 2026 - 21:00 EDT
Scheduled
Alameda County will be performing scheduled maintenance on June 11, 2026 from 6pm through to 6:30pm (PT). Filing will be unavailable during this maintenance period.
Posted Jun 11, 2026 - 10:40 EDT
This scheduled maintenance affected: California eFiling (Alameda County).