Order Outage

Incident Report for InfoTrack US System

Resolved

This incident has been resolved.
Posted Aug 27, 2026 - 15:19 EDT

Investigating

We are currently experiencing an outage and are unable to process or retrieve orders. We are working diligently to get this resolved.
Posted Aug 27, 2026 - 15:09 EDT
This incident affected: www.infotrack.com and search.infotrack.com.