eFileTX (Brooks County Superior Court) Experiencing System Issues
Incident Report for InfoTrack US System
Resolved
This incident has been resolved.
Posted Jun 29, 2022 - 10:58 EDT
Identified
Brooks County, TX is experiencing some system issues that may delay processing. Any time-sensitive filings should be filed over-the-counter until further notice.
Posted May 26, 2022 - 17:49 EDT
This incident affected: Texas eFiling.