eFileTX Payment Processing Issue
Incident Report for InfoTrack US System
Resolved
RESOLVED:
This issue is now resolved and payments are processing normally.
Posted Mar 21, 2024 - 11:54 EDT
Investigating
eFileTX is experiencing payment processing issues. Their teams are working with the payment processing vendor to resolve the issue as quickly as possible.

Thank you for your patience and cooperation.
Posted Mar 20, 2024 - 14:31 EDT
This incident affected: Texas eFiling.