eFileGA Login Outage

Incident Report for InfoTrack US System

Resolved

This incident has been resolved.
Posted Sep 01, 2026 - 11:24 EDT

Investigating

eFileGA is currently experiencing issues with logging in. The eFileGA EFM is investigating the issue and working diligently to get it resolved.
Posted Sep 01, 2026 - 11:18 EDT
This incident affected: Georgia eFiling.