UCC/SOS Searching under maintenance

Incident Report for InfoTrack US System

Identified

This issue has been identified and a fix is being worked on.
Posted May 12, 2025 - 17:31 EDT

Investigating

UCC/SOS Searching is currently under maintenance and we will have it back online as soon as possible. Apologies for any inconvenience.
Posted May 12, 2025 - 11:25 EDT
This incident affects: UCC/SOS Searching.