Riverside County Court is Performing System Maintenance
Incident Report for InfoTrack US System
Resolved
This incident has been resolved.
Posted Jan 11, 2025 - 00:44 EST
Investigating
Riverside County Court is undergoing maintenance. ALL eFiling is unavailable. We have reached out to the EFM for further information on this maintenance and will keep you posted.
Posted Jan 10, 2025 - 23:10 EST
This incident affected: California eFiling (Riverside County).