eFileTX Outage

Incident Report for InfoTrack US System

Resolved

This incident has been resolved.
Posted Nov 17, 2025 - 12:06 EST

Investigating

eFileTX is currently experiencing an outage. We are working with the courts EFM to get this fixed as soon as possible.
Posted Nov 17, 2025 - 10:30 EST
This incident affected: Texas eFiling.