Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 31, 2026 - 20:30 EDT
Scheduled
Monterey Superior Court will be performing scheduled maintenance today 7/31/2026 from 5:30 PM PST to 6:30 PM PST. Due to the nature of the maintenance, eFiling may be unavailable.
Posted Jul 31, 2026 - 19:33 EDT
This scheduled maintenance affected: California eFiling (Monterey County).