A fix has been implemented by the service provider and is being monitored.
Posted Jan 13, 2026 - 13:33 EST
Investigating
The phone service provider we use for incoming and outgoing support calls is currently experiencing intermittent issues affecting various inbound/outbound calling, message delivery, and agent status. The service provider team is actively working on a resolution. You may reach our support team in the interim via in app chat or at helpdesk@infotrack.com
Posted Jan 13, 2026 - 12:54 EST
This incident affected: InfoTrack Customer Support.