San Benito Superior Court is Experiencing Technical Issues
Incident Report for InfoTrack US System
Resolved
There was an issue in San Benito that has now been resolved by the court.
Posted Apr 15, 2024 - 14:24 EDT
Monitoring
There was an issue in San Benito County that was resolved by the court We are continuing to monitor
Posted Apr 15, 2024 - 13:45 EDT
Investigating
San Benito Superior Court is Experiencing Technical Issues and eFiling is currently unavailable. The court is aware and investigating the issue. We will provide more information as it becomes available.
Posted Apr 15, 2024 - 12:38 EDT
This incident affected: California eFiling (San Benito County).