We are continuing to monitor for any further issues.
Posted Jan 09, 2026 - 16:23 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 09, 2026 - 15:58 EST
Investigating
We are currently experiencing issues with our support chat feature. We are working with the vendor to get this fixed as soon as possible. In the meantime for support please contact us on (844) 340-3096 or email helpdesk@infotrack.com
Posted Jan 09, 2026 - 15:11 EST
This incident affected: InfoTrack Customer Support.